Ansible No Package matching found available installed or updated

При использовании модуля yum через Ansible, на новых системах RHEL / Centos Linux вы можете получить ошибку:

msg: No Package matching 'sendmail-cf' found available, installed or updated

Это вызвано отсутствием в системе пакета yum-utils.

Для его установки необходимо использовать модуль raw (аналогично установке пакета python-simplejson):

ansible 1.2.3.4 -m raw -a "yum -y install yum-utils" --user=userx --sudo

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *