Latest HP ILO firmwares

Here you can download the most recent HP iLO (Integrated Lights-Out) firmware files I could find on the HP’s website :

*UPDATED* 2017-11-13

ILO1 : ilo196.bin (30-Apr-2014)
ILO2 : ilo2_230.bin (12-Oct-2017)
ILO3 : ilo3_189.bin (iLO3 v 1.89.2 07-Jul-2017)
ILO4 : ilo4_255.bin(iLO4 v 2.55.10 16-Aug-2017)

*Note*
i got “Notice of Copyright Infringement” from HP for hosting binary firmwares on my website, so I was forced to delete them, I will try to keep links to HP website in working order.

To extract .bin files from these links unpack them:

on Linux:

$ chmod 755 CP022551.scexe
$ ./CP022551.scexe  --unpack=/tmp/iLO3
$ ls -l /tmp/iLO3
..
ilo3_180.bin
..

on Windows use 7-zip:

extract_ilo

Old versions:

ILO1:
ilo187.bin
ilo188.bin
ilo189.bin
ilo191.bin
ilo192.bin
ilo193.bin
ilo194.bin
ilo195.bin

ILO2:
ilo2_120.bin
ilo2_122.bin
ilo2_124.bin
ilo2_126.bin
ilo2_129.bin
ilo2_130.bin
ilo2_135.bin
ilo2_140.bin
ilo2_142.bin
ilo2_143.bin
ilo2_150.bin
ilo2_160.bin
ilo2_161.bin
ilo2_170.bin
ilo2_175.bin
ilo2_177.bin
ilo2_178.bin
ilo2_179.bin
ilo2_180.bin
ilo2_181.bin
ilo2_182.bin
ilo2_183.bin
ilo2_201.bin
ilo2_205.bin
ilo2_206.bin
ilo2_207.bin
ilo2_208.bin
ilo2_209.bin
ilo2_212.bin
ilo2_213.bin
ilo2_215.bin
ilo2_220.bin
ilo2_222.bin
ilo2_223.bin
ilo2_225.bin
ilo2_227.bin
ilo2_228.bin
ilo2_229.bin

ILO3:
ilo3_187.bin
ilo3_100.bin
ilo3_105.bin
ilo3_110.bin
ilo3_115.bin
ilo3_116.bin
ilo3_120.bin
ilo3_126.bin
ilo3_128.bin
ilo3_150.bin
ilo3_155.bin
ilo3_157.bin
ilo3_161.bin
ilo3_165.bin
ilo3_170.bin
ilo3_180.bin
ilo3_182.bin
ilo3_185.bin
ilo3_187.bin
ilo3_188.bin

ILO4:
ilo4_101.bin
ilo4_105.bin
ilo4_110.bin
ilo4_113.bin
ilo4_120.bin
ilo4_122.bin
ilo4_130.bin
ilo4_132.bin
ilo4_140.bin
ilo4_150.bin
ilo4_151.bin
ilo4_153.bin
ilo4_200.bin
ilo4_202.bin
ilo4_203.bin
ilo4_210.bin
ilo4_211.bin
ilo4_220.bin
ilo4_222.bin
ilo4_230.bin
ilo4_231.bin
ilo4_240.bin
ilo4_242.bin
ilo4_244.bin
ilo4_250.bin
ilo4_253.bin
ilo4_254.bin

Btsync – reset password

in case you have forgotten password for btsync Web UI, you can override it in config file.
For example on Debian it is located in: /etc/btsync/debconf-default.conf

Find webui section in configuration and add 2 options: username and password:

“login”: “admin”,
“password”: “password”

So “webui” configuration section will look like this:

        "webui" :
        {
                "directory_root" : "/var/btsync",
                "listen" : "0.0.0.0:8888",
                "force_https" : true,
                "ssl_certificate" : "/etc/btsync/debconf-default.crt",
                "ssl_private_key" : "/etc/btsync/debconf-default.key",
                "login": "admin",
                "password": "password"
        }

Now restart btsync serviceby running:

service btsync restart

You can now login using username “admin” and password “password” and reset password in WebUI.

Raspberry Pi 3 disable bluetooth and wifi

To completely disable WiFi and Bluetooth by disabling kernel modules in Raspbian / OSMC add following lines to
/etc/modprobe.d/raspi-blacklist.conf

#wifi
blacklist brcmfmac
blacklist brcmutil
#bt
blacklist btbcm
blacklist hci_uart

Kodi video buffer cache location

When you disable RAM caching by setting “cachemembuffersize = 0” in .kodi/userdata/advancedsettings.xml Kodi will write video cache to disk.
Video cache will be written to kodi temporary folder:

~/.kodi/userdata/temp

with filename:

filecache000.cache

transaction check error – mysql-community-libs-compat conflicts with file from package compat-mysql51

While upgrading MySQL server on centos 6 from 5.5 to 5.7 you may encounter following error:

Transaction Check Error:
  file /usr/lib64/mysql/libmysqlclient.so.16.0.0 from install of mysql-community-libs-compat-5.7.11-1.el6.x86_64 conflicts with file from package compat-mysql51-5.1.54-1.el6.remi.x86_64
  file /usr/lib64/mysql/libmysqlclient_r.so.16.0.0 from install of mysql-community-libs-compat-5.7.11-1.el6.x86_64 conflicts with file from package compat-mysql51-5.1.54-1.el6.remi.x86_64

It can be resolved by running following yum transaction:

$ yum shell
> remove compat-mysql51
> install mysql-community-libs-compat
> run

This will update affected mysql libraries to newer version without breaking any dependencies.